A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 03:13 UTC
Investigating
We are currently investigating this issue.
Posted Jun 24, 2025 - 02:55 UTC
This incident affected: NORD-NO-KRS-1 - Norway Datacenter (NORD-NO-KRS-1: CPU Hosts, NORD-NO-KRS-1: GPU Hosts, NORD-NO-KRS-1: Network Connections) and Public API (api.genesiscloud.com).