Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 8 days ago. Mar 24, 2025 - 10:37 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted 13 days ago. Mar 19, 2025 - 10:40 UTC
Scheduled
We will be performing maintenance work in our Norway Datacenter from Monday, March 24th to Friday, March 28th. During this period, there may be short service interruptions.
Affected Customers: All users with NVIDIA RTX 3090 & RTX 3080 instances. Action Required: RTX 3090 users must stop and start their instances between March 22nd and ideally March 25th to ensure smooth operation. Reminder: Please secure your data ahead of time to prevent any potential disruptions.
Thank you for your understanding and cooperation! — your Genesis Cloud Team
Posted 13 days ago. Mar 19, 2025 - 10:39 UTC
This scheduled maintenance affected: Console dashboard (console.dashboard.com), Public API (api.genesiscloud.com) and NORD-NO-KRS-1 - Norway Datacenter (NORD-NO-KRS-1: CPU Hosts, NORD-NO-KRS-1: GPU Hosts, NORD-NO-KRS-1: Network Connections, VAST filesystem).